Go Back   Lynx - The Community Forums > The Discussion Corner > Our - Other Services

Our - Other Services All Other Services That We Provide Other Then Data Recovery Are Listed Under This Section .Kindly Do Not Post Data Recovery Questions Here .We Have Another Section For Those .

Reply
 
Thread Tools Display Modes
Old 07-11-2013, 10:10 PM   #1
Amarbir
The Boss
 
Amarbir's Avatar
 
Join Date: Jan 2010
Location: Chandigarh
Posts: 3,384
Amarbir is on a distinguished road
Send a message via MSN to Amarbir Send a message via Yahoo to Amarbir Send a message via Skype™ to Amarbir
Default Tutorial - Experiences In UPS Repair [ Numeric 500 VA ]

Hi ,
I Got a UPS From One Of My Cousins " Sanjam Badal " .Once This Unit Was Opened I Realized That This Plastic Cabinet is a "POS " - Piece Of Shit .Try Not To Buy UPS That Have Plastic Complete Bodies .The Plastic After Time Due To Heat Just Starts Disintegrating Like Anything .Anyways I Took The Mainboard Out And Realized More Then 75% of The Plastic Screw Retainers Were Broken . Damn i Thought 24 Hours Wasted "Cos i Had To Join Then With Glue .I Avoid Elfy Always .I Think Other Glues Have Better Strength .Well After 24 Hours I Started To Test The UPS .And Now The Story Follows .

Battery Replacement

" Photo Would Be Posted Soon "


Well The First Thing Would Be Testing The Battery .I Tested The Same And It Had Less Then 1 Volts DC Damn "Battery Should Be 12 Volts Plus Mostly "Approx 13.7 Volts " . Then i Tried To Charge The Same "Its Deep Discharged " But It Did Not Charge .Hence The Battery Was Kaput .Replacement of The Same With a New 7 AH 12 Volt Battery Got The UPS Back To Life " This Unit Has a Microcontroller Circuit .All Good So Far Now Lets Put This Thing Back ,Spark ? [ What , Where , How ] .I Sensed a Spark And It Did Not Happen Again .Well I Though Might Be Mainboard Touched Something Metallic .No Worries .

The Rattle Sound

"Photo Would Be Added Soon "

Once This Unit Was Closed "Damn Ask Me Not How Bad It Was To Close This POS Cos Of This Cramped Horrible Plastic Case" And The UPS Was Operated "On Battery Mode I Was Hearing a Transformer Hummmm Greater Then It Should Have Been .Well i Though I Had Discharged The Battery Before The Case Was Closed So Might Be Due To Discharged Battery The Same Is Humming More Then it Should .Well Well Well Lets Charge The Damn Thing And Test It Later .

The Fireworks

"Photo Would Be Added Later "

After The Battery Was Charged " Hopefully " After Few Hours I Started The UPS And Switched Off Main Supply To The Same .The UPS ASAP Came To Battery Mode And i Heard The Same Rattle And Guess What "Fireworks " The UPS Mosfet Section Was On Fire .I Did All What a Engineer Could Do And The Fire Was Put Off .Time To Open The Beast again Damn .Puff The PCB Near The Mosfets Was All Black And a Mess .I Took The Mainboard Off The Case And Desoldered The Mosfets " P60NF06 " 4 Units " 2 In Parallel " On Each Side Of The Transformer Winding " 4 In Total OR 2 Pairs " . The Same Heatsink Had a LM317 Adjustable Voltage Regulator Also For The UPS Charging Section .This UPS Charges The 7 AH Battery At 500 mAh "Tested By Me " .

The Repairing Process

"Photo Would Be Added Later "

I Took My Trusted Protek 608 Multimeter And Tested The Mosfet "1 Was Blow Up " And " The Other Was Totally Short " . The LM317 Section Was Safe .I Also Tested The Gates Section Of All The Mosfet And Also Other Components Close To The Mosfet Area "All Seemed Fine " .Well Tried To Locate The P60NF06 From My Vendor "Though i Have Cartloads Of Non Sorted Semiconductor Mosfets " But i Could Not Find The Same .This Mosfet Is Rated AT 60 Volts @ 60 Amps .He Had The P55NF06 That Was 60 Volts @ 50 Amps "10 Amps Less " .There Was a Difference In RDS Also "Resistance Between Drain And Source " Little Bit .As i Had No Choice i Used These And Soldering The Mosfet Section Back To The Mainboard .

The Testing Process

" Photo Would Be Added Later "

I While i Was Repairing This .I Was Wondering What The Hell Went Wrong ? .And Guess What I Saw That The Two Leads That Goes In The Two Different Sides Of The Transformer "One Of That Was Not Connecting To The Mianboard "Due To The Fact That The Male Thimble Connected To Mainboard Due To Pressure Of Putting This POS Back Had Dislodged From The PCB And Was Free " Creating Sparks .Damn i Now Got The Mystery Solved .So i Had To Solder That Male Thimble Also To Mainboard With Good Amount Of Solder . So i Connected All The Cable To The Mainboard Back And Pressed The On Button "Fireworks " Damn No It Worked .Now i Am Just Testing The Same And Once I Am Done With Testing I Am Going To Put The Case Back .I Will Also Discuss Some Engineering Notes For Newcomers To Solve Issues Like This .

Engineering Notes

  • Mosfets In UPS Are 2 Channel "Mostly " .This Means 1 Channel Mosfet Works At 1 Time And Then It Shuts Off And The Other One Works .Generally When You Repair These UPS You Will Tend To Replace The Bad Mosfets Only .I Changed All 4 [ 2 In Pairs Each ] .Why Did I Do That ? .I did That So That Both The Channels Of The Mosfets Have Same Type Otherwise There Could Have Been a Imbalance P60NF06 At One Side And P55NF06 At Other .
  • Why Did i Settle For 10 Amps Rating Less UPS Mosfet .Simple My Cousin Uses a LCD Not a CRT Monitor .CRT Monitors Draw Huge Surges And Could Blow The P55NF06 Up If He Had One
  • Always Check All Section Sending And Recieving Signals From Mosfet Section if It Blows Up .Otherwise You Can Blow It Again
__________________
Amarbir is offline   Reply With Quote
Old 07-12-2013, 06:40 PM   #2
manoj soorya
Junior Member
 
Join Date: Feb 2013
Posts: 8
manoj soorya is on a distinguished road
Default

If you attached a photo, the problem will understand more....

Thanks

Manoj Soorya
manoj soorya is offline   Reply With Quote
Old 07-12-2013, 08:00 PM   #3
Amarbir
The Boss
 
Amarbir's Avatar
 
Join Date: Jan 2010
Location: Chandigarh
Posts: 3,384
Amarbir is on a distinguished road
Send a message via MSN to Amarbir Send a message via Yahoo to Amarbir Send a message via Skype™ to Amarbir
Default

Quote:
Originally Posted by manoj soorya View Post
If you attached a photo, the problem will understand more....

Thanks

Manoj Soorya
Surya ,
This Would Be Done Today ,I Will Repost In The Thread Once Its Done
__________________
Amarbir is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +5.5. The time now is 05:19 PM.
Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
The Lynx Group Community Forums

A vBSkinworks Design